DF2014 Talk:Known bugs and issues

From Dwarf Fortress Wiki
Jump to navigation Jump to search

Does anyone know if 1451 is ever going to get fixed? Why is it set to minor? unsigned comment by 216.159.180.2

  • Only Toady knows whether it will be fixed, and he doesn't read the wiki for bug complaints so it's kind of pointless to ask here... --Quietust (talk) 15:47, 10 September 2014 (UTC)
In addition, Toady ignores the severity and priority fields (except when set to "crash" or "block") - the status field is our primary method of communicating an issue's priority to Toady, and that issue has it set to "confirmed", which is the highest possible status for unfixed issues. —Lethosor (talk) 18:53, 10 September 2014 (UTC)

Bugs in old versions[edit]

The old versions of this page say "Please report bugs in Mantis". But bug reports for old versions are useless because who knows if they've been fixed in the meantime? And bugs in removed features will never be fixed. I suggest adding the following to all old versions:

  • Please do not report new bugs in versions before 0.40.01. Such reports will be ignored. Instead, try to reproduce them in the current version. If you succeed in reproducing it, report it as a bug in the current version instead.

And possibly something for this page too, since this namespace spans (so far) four major version numbers. I'd add this myself but I don't want to speak for the people who actually manage the bug tracker. Hairy Dude (talk) 11:15, 29 August 2018 (UTC)

I updated the intros on the historical pages.--Loci (talk) 01:29, 30 August 2018 (UTC)

Bug years[edit]

I am unconvinced that the year a bug was reported is useful information for this page. Any thoughts?--Loci (talk) 22:15, 10 April 2019 (UTC)

Corrupted military equipment crashes[edit]

In the Severe bugs section, currently the first two items are crash from corrupted military equipment, and crash when returning from mission, which I suspect is also caused by corrupted military equipment. I suggested avoiding this by avoiding running v0.44.*, instead using v0.43.*. Loci changed that to a recommendation to avoid raiding. But I've had persistent corrupted equipment crashes without raiding, so I think recommending avoiding v0.44.* is the better recommendation: http://bay12games.com/dwarves/mantisbt/view.php?id=11041 Darxus (talk) 06:25, 12 April 2019 (UTC)

Neither of the entries you modified references that bug report. The bugs that are referenced have multiple saves, significant investigation, and a very probable link to raiding. Your crash, on the other hand, is not avoidable by disbanding all military squads, so it is likely *not* caused by corrupt military equipment lists. In general, recommending people play a version from 12+ releases ago is problematic since those versions lack many new features, reinstate a bunch of already-fixed bugs, and make any bugs reported by those players nearly worthless.--Loci (talk) 19:47, 12 April 2019 (UTC)
Can we somehow mention that the first two crash bugs were introduced in v0.44.*? Darxus (talk) 01:13, 13 April 2019 (UTC)